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Overview:

This document describes outstanding issues, new features and enhancements included in DeltaGraph 5. This 
release is available for Mac OS X 10.1.5 or later and MacOS 9.x.  For more DeltaGraph product information 
please visit:
<http://www.redrocksw.com>.

Please note that the DeltaGraph 5 User's Guide was updated for version 5.5.  A PDF version is installed along 
with DeltaGraph.  The default location is /Applications/DeltaGraph 5/User Documentation/.
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0. Installation
To Install DeltaGraph 5, double click on the "Install DeltaGraph 5.5" icon and follow the instructions.

I. Version History

v.5.5.1
-Slide shows are now rendered using Quartz graphics
-Includes the following bug fixes:

-Using the Draw->Object Attributes menu command no longer crashes DeltaGraph under Mac OS 9
-Using the File->Export->As Other... command no longer crashes DeltaGraph under Mac OS X 10.1.5
-Fixed a problem that can cause DeltaGraph to crash when attempting certain AppleScript commands
-Exporting JPG images via AppleScript works correctly again (was only a problem in 5.5)
-Importing tab-delimited files via AppleScript now works as expected

v. 5.5
-New Features For Both Mac OS X and Mac OS 9:

-Drag and drop data import.  Data files (including delimited text files and Excel files) can be imported by 
dragging them into the  data view.

-Drag and drop image import.  Files of supported formats may be dragged into the chart view.
-Drag and drop export to other applications.  Charts and other objects or groups of objects may be dragged 
to other  applications which support graphic imports.

-Support for copy/paste of custom delimited data (tab, space, comma).  A new item has been added to the 
Edit menu called  "Paste Delimited".  After copying data from a space, tab, or comma-delimited file the 
"Paste Delimited" menu item should be  chosen in DeltaGraph.  You will then be asked to specify the 
delimiter and the data will be added to the data sheet.

-Additional export formats are now available (standard Quicktime list).
-Snap to grid feedback while dragging has been implemented
-Some key modifiers have changed.  In the past, option-drag has had the effect of ignoring snap-to-grid.  
This functionality has been changed to be more consistent and modern.  Now, option-drag will create a 
copy of the object if the drag is to the same document.  To ignore snap-to-grid you should now use 
command-drag.  Command-option-drag now creates an EGO copy of your chart in the target application.

-Toolbox position is now saved when you quit DeltaGraph
-Several new keyboard shortcuts are available:

-Command-Shift-G does the same as going to the Draw menu and choosing Group
-Command-Shift-U  does the same as going to the Draw menu and choosing  Ungroup



-Command-Shift-D  does the same as going to the Draw menu and choosing Shadows
-Command-Shift-C  does the same as going to the Edit and menu choosing Colors

-Pantone half-tone color support in EPS image exports.  To use this feature your object must have a 
Pantone fore-color and a white background color.  You must then choose a pattern from the last 32 
patterns (last 2 rows) in the pattern palette with each progressive pattern representing roughly a 3% 
increase in the tone.  An exported EPS file will maintain the Pantone named color and a half-tone value 
based on the pattern.  Any other export type will interpret the pattern as a normal pattern rather than a half-
tone value.

-New Features Specific to Mac OS X:
-PDF Import.  DeltaGraph can now import PDF images to chart pages.
-PDF Export.  PDF has been added as one of the supported export formats.  Rather than printing to PDF, 
which prints the whole  chart page, you can now export individual charts or objects as PDF images.

-Improved export quality on non-embedding export formats (JPG, BMP, TIFF, etc.).  Our export  process has 
been retooled to take full advantage of the Quartz engine when exporting these image types.  Any 
applicable export options (such as the standard JPG Quality slider) are also available.  This gives users 
the ability to produce some extremely high-quality images no matter what format is used.

-Export resolutions up to 1200 ppi are now available for all export formats.
-All text is now fully rendered using Quartz.
-Transparency support.  You can now add transparency using the new transparency tool in the tool palette.  
Transparency  effects will be maintained if you export the image in all formats except for EPS or PICT.  
Transparency layers are maintained  when you export the image as a PDF.

-Support for soft drop shadows when running on Mac OS X v.10.3 or higher. Running on 10.3+, 
DeltaGraph, provides an additional option in the Shadow dialog.

-Also included are many bug fixes.  The following problems are among those fixed for this version:
-A problem where double-clicking the DeltaGraph title bar (for window shading) in OS 9 made the window 
disappear

-Several similar crashes caused by importing Excel files
-A problem where JPG and other images exported at higher resolutions were getting shrunk
-A registration problem where typing a company name that exceeds 31 characters caused DeltaGraph to 
reject the serial number

-A multi-user environment problem where users other than admin were not able to access the standard 
library.

-When opening a very large file the watch cursor now appears.
-A crash caused by removing data after using it for a curve fit
-Superscript and subscript characters no longer move during export
-When the axis is a date, the up and down arrows in the Value Axis dialog now adjust the Beginning and 
End dates according to the Minor Increment rather than in seconds.

-Scrolling should no longer produce drawing problems
-Out of range alert should no longer be triggered when opening the Overlay Dialog.
-A crash seen when trying to export Multiple Pie chart
-Copy/Paste now working from data view to chart view
-A problem where chart page names were showing up incorrectly
-Adjusting pie chart depth should no longer throw an error
-A problem where Symbol Font characters were showing up incorrectly.
-Year format now defaults to four digits for all years rather than only years after 2000.  This also addresses 
a problem found when changing axis start or end dates when there is a mix of year formats. 

-"Set All" key command should be working again
-Crash no longer occurs on startup when system language is set to Japanese
-A problem where highlight color can get progressively darker
-Highlight should no longer get reversed when editing bullet lists
-A problem where lines can be printed too thick under some circustances
-A bug where symbols weren't being exported in some cases
-Line length in legend symbols is now adjustable for all chart types
-A very old problem where charts may not be properly updated with the correct data under very specific 
circumstances

-Table charts can now be plotted with only one column of data
-A problem where rotated text can appear to go away after a font size change



v. 5.0.2
Includes the following enhancements:
-Support for MacOS 9
-Updated Microsoft Excel file import and file linking capabilities.  For instructions on using this feature see 
the "Data Linking.pdf" document included in the DeltaGraph 5/User Documentation folder.

-Text file data linking has been reinstated.  For instructions see the "Data Linking.pdf" document 
mentioned above.

-Several bug fixes

v. 5.0.1a
Primarily includes bug fixes for the following issues:
- A fairly rare problem where DeltaGraph may report that there is another user with the same serial 

number on the network when that's not the case.
- A problem where some rotated text was being moved upon print/export.

v. 5.0.1
Primarily includes bug fixes for the following issues:
-A problem which can cause DeltaGraph to crash upon startup for some users.
-A bug which causes DeltaGraph to crash after updating a linked Excel file.  

v. 5.0
The primary new feature in 5.0 is native support for Mac OS X. In addition to a fully aquafied user interface, 
support for Quartz rendering for graphics and text is included. PDF export (via the Print dialog) is also 
supported.

II.  Known Issues and Work-Arounds:
Raster image export types (JPG, BMP, TIFF, etc.) are limited to 4000 pixels in width because of a 
Quicktime bug.  Apple is aware of the problem.  If you try to export an image at a resolution that would 
exceed 4000 pixels you will be asked to lower the resolution and try again.

There was a problem in the 5.5 installer which resulted in the "~MathType Fonts" file being installed to the 
/Library/Fonts/ or Home/Library/Fonts/ folder.  This file should be removed from those directories and 
placed in your DeltaGraph 5/Equation Editor folder.  The 5.5.1 updater will offer to do this for you.  See the 
following article for more information:
http://support.redrocksw.com/dgknowledge/question.php?qstId=224

Mac OS X users who have Quicktime 5 installed may see a problem where all raster-type images (any 
from the "File->Export->As Other..." list) get exported as 100 x 100 pixels.  This is a Quicktime bug and can 
be solved by updating to the newest version.  This problem will only be apparent with DeltaGraph 5.5.1.

Users who run DeltaGraph under Mac OS X v.10.3 may experience a graphics glitch after launching 
DeltaGraph.  The first page that DeltaGraph opens may not draw completely.  This appears to be a system 
bug in 10.3.  We are working on a solution.  Changing to chart view and back or closing and reopening the 
document will fix the glitch and it will not reappear while DeltaGraph remains running.

The DeltaGraph 5.5 installer will install the DeltaSym, DeltaSymbol.TT, MT Extra, and MTExt fonts in one 
of two places: /Library/Fonts or Home/Library/Fonts.  If you are a non-administrative user with no write 
access to the root-level Fonts folder then the installer will place the fonts in your user-level fonts folder.

For this release the text tool is not able to create fully justified text.

Due to a system bug we do not support using Quartz soft drop shadows with any object which uses a 
pattern.  Doing so may cause DeltaGraph to crash when printing the object.  The bug has been reported to 
Apple.  Please note that Quartz soft drop shadows are only available if you are running Mac OS X v.10.3 
higher.  The workaround is to export the image first and then print it.

Exporting charts via EPSF has potential problems with printing, since fonts used in an EPSF file are not 
automatically downloaded to a printer. This is a general issue with Mac OS X.  See the following article for 
the workaround:



http://support.redrocksw.com/dgknowledge/question.php?qstId=188

The Pantone™ color set has changed since DeltaGraph 4.5 for Macintosh. Because of this, Pantone™ 
color names will not be preserved for files created in DeltaGraph 4.5 when opened and saved in 
DeltaGraph 5 (however the color information will be correct).

DeltaGraph help will display in your default browser ( set in the Web tab of the Internet pane of System 
Preferences ). We recommend Safari, any of the Mozilla-based browsers ( Mozilla, Communicator, 
Camino, etc.), or Microsoft Internet Explorer. 

III.  Contacting Technical Support

-To open a technical support case or to access our knowledge base or discussion board please visit our 
support website: 
http://support.redrocksw.com

-For technical problems which cannot be resolved using the above resources, contact technical support by 
e-mail or telephone.  When contacting us via e-mail PLEASE INCLUDE A NOTE ABOUT THE VERSION 
OF DELTAGRAPH YOU ARE USING ALONG WITH YOUR OPERATING SYSTEM AND A DESCRIPTION 
OF THE PROBLEM.  This will greatly speed up the process of providing a solution for your issue.

E-mail: dgsupport@redrocksw.com
Phone: (801) 363-2485 Mon-Fri 9:00 AM - 5:00 PM Mountain Time 

To be eligible for technical support please register your copy of DeltaGraph here:
http://support.redrocksw.com/registerdg5mac

The DeltaGraph Team
Red Rock Software, Inc.
10 West Broadway, Suite #475
Salt Lake City, UT 84101
(801) 322-4322


