DeltaGraph 5.7.5 for Macintosh ReadMe

Overview:

This document describes outstanding issues, new features and enhancements
included in DeltaGraph 5. This release is available for Mac OS X 10.1.5 or later and
MacOS 9.x. For more DeltaGraph product information please visit:
<http://www.redrocksw.com>.

The 5.7.5 update provides fixes to several bugs as listed in Section I.

If you are installing 5.7.5 as an update, you must have DeltaGraph for Mac version
5.5.1 or later installed. If you have a version of DeltaGraph previous to 5.5.1 please
download and run the 5.5.1 updater before trying to install the 5.7.5 update. You can
download the 5.5.1 update here:

http://support.redrocksw.com/downloads/

This update is recommended for all users.

In this ReadMe

0. Installation
I. Version History
II. Known Issues and Work-Arounds

lll. Contacting Technical Support
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0. Installation
To Install DeltaGraph, double click on the installer and follow the instructions.

I. Version History
v.5.7.5
-New features:
-Added "Check for Updates" feature.
-Addressed the following issues:

-Fixed conflict between "Revise Data" command key and "Preferences..."
command key by changing "Revise Data" command-key.

-Fix for magically changing fonts in text areas using non-roman characters.

-Fix for broken resolution setting for exported images on Intel Macs.

-Improvements to rendering and bookkeeping code for included EPS images.

-Installer was sometimes incorrectly setting permissions on the DG Stationery
file to other:none, causing a -5000 error when trying to create a new file.

v.5.7.4
-Addressed the following issues:

-Fixed problem which caused text labels and chart symbols to be missing or
vertically offset from their correct positions in PICT export. This problem would
also be visible in charts copied and pasted into Microsoft Excel, for example.

-Fixed problem which, in some circumstances, could cause DeltaGraph to crash
when opening the Curve Fit dialog.

-Fixed problem which caused colors in certain DeltaGraph 5 for Windows files to
be corrupted when inporting into DeltaGraph for Macintosh

-Fixed problem with some alert dialogs displaying random text.

-Fixed problem which caused problems opening a few DeltaGraph 5 for
Windows files that had been converted from DeltaGraph 4.x for Windows files.

-Fixed problem with the View Scale menu, which was not displaying correctly



when custom scaling was selected.

-Fixed problem with curve fitting when the "force through zero" option was
selected. The same R”2 value would be displayed as when "force through
zero" was unselected.

-Fixed problem which prevented rendering of TIFF data in files created by
versions of DeltaGraph older than version 4.5, when rendering in Mac OS X.

-Fixed problem which may have caused rendering problems with EPS data
when multiple EPS images were included in a file.

-Fixed problems which may have caused a failure to open files created by
versions of DeltaGraph older than 4.0 when they included EPS images.

-Fixed problem with reading and writing EPS data embedded in DeltaGraph
files

-Fixed problems running DeltaGraph in Mac OS 9

-Fixed problems running DeltaGraph in Mac OS X 10.2.8 and earlier.

-Fixed problems with cross-platform compatibility of DeltaGraph files.

-Fixed a problem that sometimes caused misalignment of labels when opening
pre-existing files in the Japanese version of DeltaGraph.

-Fixed various problems reading and writing files created with earlier versions of
DeltaGraph for Mac OS.

-Fixed problems with reading and writing Radar and Donut charts

-Fixed problem with vertical alignment of multi-line labels.

-Fixed problem with patterns in exported EPS when running on Intel Mac
hardware.

-Fixed problem which prevented applied layouts from sticking to chart canvases.

-Fixed problem with use of more than one transition in a slide show.

-Added back the ability to drag slides from one document to another from within
the slide sorter view.

-Fixed crash when opening certain old files when running on Intel Macs.

-Fixed vertical label alignment in exported EPS images with certain Japanese
fonts.

-Fixed vertical label alignment in QuickDraw output (PICT export and copy and
all rendering when running in Mac OS 9)

-Added Default Slideshow Transitions

-Optimized file saving times

v.5.7.3
-Addressed the following issues:

-Fixed problem with writing DeltaGraph files which prevented them from being

read by DeltaGraph for Windows.

v.5.7.2
-Changed Behavior:
-Show Values Dialog:

In the Show Values Dialog (menu item "Chart -> Show Values"),
changing the location of the shown values (by changing the item selected in
the Location popup) resets the positions of the values being displayed. That is,
if the user has moved one or more of the shown values manually (by clicking
and dragging in the chart view), changing the location via the popup will reset
the positions of those values to the defaults for the location chosen in the
popup. This is different than the old behavior, which tried to relocate the
manually positioned values based on the new location setting. We think this
new behavior is more in line with what users expect.

-Addressed the following issues:

-Loading color palettes within scripts is broken.

-Pasting charts into Microsoft Office sometimes caused chart symbols to become
large.

-Locking of draw objects is not working.

-Can't delete chart sheets.

-Fixed problem reading some old DeltaGraph files which included user-defined
curve fits.

-Fixed problem reading some DeltaGraph 5.x Windows files.



-Format of data cells is lost when opening DeltaGraph 5.x Windows files.

-When running DeltaGraph 5.7 or 5.7.1 Mac on an Intel Macintosh, importing
DeltaGraph Windows files sometimes corrupts the data sheet

-Problems opening DeltaGraph 5.x Windows files with data cells formatted as
date/time.

-Can't open DeltaGraph 3.5 Mac files.

-Can't import DeltaGraph 5.x Windows files which include links to Excel files.

-Crashes when in split-window mode.

v.5.7.1
-Addressed the following issues:
-Not able to open DeltaGraph 5.x for Windows files when running natively on
Intel Macintoshes.
-XY Coordinates (position, object size, etc.) were not being correctly displayed
in the status bar.

v.5.7
-New features:
-Native support for Intel based Macs (Universal Binaries).
-Better support for multi-user systems.
-Control over alignment of labels with superscripts and subscripts.

Normally, labels are aligned so that their tops are aligned. With the changes
in this version, the labels can optionally be aligned by their baselines. To
change the alignment of labels for a chart, select the chart, and press
Command-Option-R. To change back to the default alignment, hit Command-
Option-R again.

-Addressed the following issues:
-Several crash bugs
-Not able to relink to data file if the linked file was moved
-Back edge line on 3D column charts not visible
-Drop shadows don't work with arrows or lines
-Improved layout of label text in charts

v.5.6.1
-Addressed the following issues:

-Several crash bugs

-Problems with crumpled text in Formula Editor in Japanese DeltaGraph.

-Fixed problem with eps export of Japanese text that contained English
characters

-Problems with crumpled text when creating layouts in Japanese DeltaGraph
when the input method is set to English.

-Problems with crumpled text when applying layouts in Japanese DeltaGraph
when the input method is set to English.

-Bug when printing from the Finder, which caused the Print dialog to not be
opened.

-Bug which caused message text to overflow its area in the status bar (Japanese
DeltaGraph only).

-Bug in Snap To Grid behavior which kept objects from properly aligning with
the drawing grid

-Bug which caused crumpled text to be drawn when editing Master Background
(Japanese DeltaGraph only).

-No text appears in table chart after creation (Japanese DeltaGraph only)

-Parts of table charts have crumpled text (Japanese DeltaGraph only)

-Bug which caused DeltaGraph to crash when displaying the Print Dialog for
certain Canon Bubbledet printers.

-Bug which sometimes prevented the Paste Pictographic... command from
working correctly when trying to paste objects created in DeltaGraph.

-Bug which caused added axis labels to be crumpled when added to some chart



types (Japanese DeltaGraph only).

-Problems importing some Excel files.

-Problem which caused errors when clicking the "Calculate Now" button with
loaded curve fits.

-Problems with Axis dialog with 3D Scatter charts

-A bug in the Shadow Dialog which caused the shadow control to be incorrectly
drawn when the shadow was set to a pattern and the background color was
anything other than white. This did not affect shadows on objects in the chart
view.

-Improved snap-to-grid alignment and object placement when dragging charts &
other draw objects.

-Several problems with opening DeltaGraph for Windows files were fixed

-Corruption message under some circumstances when linking to an Excel file

-User defined curve fits from sample files throw error message when being
applied

-Layouts can't be applied under some circumstances

-Unable to import Windows Excel file

-Text corrupted in Calculation area of Formula Builder when calculations are
performed across data pages

-Settings specified in Axis Placement dialog are sometimes applied to the wrong
axis

-Axis ticks and labels incorrectly being turned off along with gridlines

v.5.6
-New features:

-DeltaGraph 5.6 Mac will read DeltaGraph 5.x Windows files.
-Control-clicking (or right-clicking) when using the Text Tool in the Chart View
now creates a bullet list
-Bullet list attributes can now be edited from the Chart View (when editing a
bullet in the list you can now get the Bullet Editor window to come up by going
to the Text menu and choosing "Edit Bullets..."
-Greatly improved speed of text data import (up to 20 times faster for large data
sets)
-Added import options for text data import. When importing text data files you
will now see a dialog which allows you to choose the import location, etc.
-Added option to Pie Chart Options dialog to enable users to enable/disable the
border around pie chart slices
-When editting colors, users can now choose to edit CMYK colors (ratherthan
the default RGB colors). When colors are created in this way, they are stored by
DeltaGraph as CMYK colors, working around issues with Apple's Color Picker.
This allows users requiring precise CMYK color output in their EPS files to
specify them precisely.
-Quartz Blends: Line and Oval blends can now be optionally rendered using
Quartz Shaders, resulting in improved quality in some circumstances.
-Improved Oval Blends (non-Quartz Shader based)
-Imported EPS files are now rendered to screen and to printer via CoreGraphics,
which means higher quality output. The preview images sometimes added to
EPS files are no longer used by DeltaGraph for rendering either to screen or to
printer. Rather, the PostScript™ code is interpreted for rendering purposes.
-Improved rendering of Arcs, Bezier, and Freehand shapes, as well as Curve Fit
curves. They are now smoother and more precise.
-More accurate rendering of all drawing elements. DeltaGraph now renders
using all the floating point precision of Core Graphics.
-Improved Copy-Paste, Drag-Drop behavior. Now, when the user copies any
draw element from a drawing canvas and pastes it back into a DeltaGraph chart
view, it remains a DeltaGraph draw element, editable in every normal way.
-CricketGraph data files can be imported to a DeltaGraph data sheet. To
accomplish this, drag the CricketGraph file into a DeltaGraph data sheet.
CricketGraph file import is not an option in the File Import dialog.



-Fixed the following bugs:

-Major improvents to stability which should prevent many random crashes

-Value Axis dialog not working properly when using secondary axis

-Fixed a cosmetic problem in the status bar

-Pop-up in library opens in wrong display

-Grouped objects can't be ungrouped when pasted into new DeltaGraph page

-Clipboard data contents disappear when leaving DeltaGraph in OS 9

-CMYK color values seem to get changed incorrectly

-Binning dialog hides/shows label popup incorrectly

-Buttons in Formula Builder don't show up in Mac OS 9

-Option-dragging text objects loses formatting

-Crash when clicking "?" button in the Set All dialog

-Chart Gallery always defaults to creating charts in a new page (fixed in
Stationery file)

-Crash when opening formula builder in 10.1.x

-Text inserted into text objects carriage returns after each character

-Hitting Return in Curve Fitting dialog does weird things

-Error bars show up twice for bar chart when using an axis break

-Drawing problem with list control in Excel import dialog

-Crash in Edit Colors dialog in file imported from version 2.x

-Crash when trying to export chart as EPS/PICT

-Arcs don't get drawn correctly

-Pop-up not updating correctly in Error Bars Dialog

-Crash under some circumstances when trying to open DG file that has been
linked to an Excel file and the Excel file is not available

-Memory error when trying to plot Intensity Scatter chart with just under 32K data
points

-Text objects start putting one character per line after highlighting and deleting a
whole line

-Can not get a curve fit with a log X axis under some circumstances

-Custom font size not displayed or remembered in Symbols dialog

-Spinners for Left and Right values don't work in Value Axis dialogs

-Error bars for overlay chart with additional axis not visible

-Crash when opening Curve Fit dialog in 10.1

-Changing major or minor units for time axis doesn't correctly disable Auto
features

-Counters stay active when scaling changes in Value Axis dialog

-Major and Minor Units pop-ups aren't reset when changing back to Linear scale
in Value Axis dialog

-Counters aren't disabled when Automatic checkbox is checked in Value Axis
dialog

-Cosmetic: Cursor always drawn in "Right Value" text field in Value Axis dialog

-Fields not updated when Auto checkbox clicked in Value Axis dialog

-Label wrong when Value Axis dialog opened and scale is Date/Time

-Crash when holding down ctrl key or right clicking when creating a text object

-Escape key deletes objects

-Axis placement controls disabled for Bubble charts

-DeltaGraph won't open files on a read-only volume

-Greek/other special characters in axis labels get changed to Japanese
characters when opening the axis labels dialog

-Crash when using pattern fills with shadows

-Border not showing up in pie chart slices

-Several problems relating to the display of international text in the user
interface

-Minor problems in status bar

-Problems with text EPS export

-Arcs not being drawn correctly (wavy lines rather than smooth curves)

-Problem with PDF export of labels with hard breaks ("\r"). lllustrator renderins
the label with a "!" at the end of each line with a hardbreak.



-Tick mark at origin not drawn properly with reversed axis and axis break and
other related issues relating to ticks and axis breaks.

-PDFs are being drawn slightly offset of where they should be

-Minor problem with the DG Stationery file.

v.5.5.2
-Fixed a bug where text created using the text tool was not being drawn to the
screen under Mac OS X 10.1.5. This bug appeared in versions 5.5 and 5.5.1
-Fixed a problem where the degree symbol used in some charts was being
incorrectly drawn for Japanese systems
-Fixed a problem where some large Japanese Excel files could not be imported
-Fixed a bug where the interface for setting high, low, middle symbols in High-Low
and Range charts was missing under some circumstances
-Fixed a problem where going to the Page Title dialog can lead to a crash under
some circumstances under OS 9.

v.5.5.1

-Slide shows are now rendered using Quartz graphics

-Includes the following bug fixes:
-Using the Draw->Object Attributes menu command no longer crashes
DeltaGraph under Mac OS 9
-Using the File->Export->As Other... command no longer crashes DeltaGraph
under Mac OS X 10.1.5
-Fixed a problem that can cause DeltaGraph to crash when attempting certain
AppleScript commands
-Exporting JPG images via AppleScript works correctly again (was only a problem
in 5.5)
-Importing tab-delimited files via AppleScript now works as expected

v.5.5
-New Features For Both Mac OS X and Mac OS 9:
-Drag and drop data import. Data files (including delimited text files and Excel
files) can be imported by dragging them into the data view.
-Drag and drop image import. Files of supported formats may be dragged into the
chart view.
-Drag and drop export to other applications. Charts and other objects or groups of
objects may be dragged to other applications which support graphic imports.
-Support for copy/paste of custom delimited data (tab, space, comma). A new item
has been added to the Edit menu called "Paste Delimited". After copying data
from a space, tab, or comma-delimited file the "Paste Delimited" menu item
should be chosen in DeltaGraph. You will then be asked to specify the delimiter
and the data will be added to the data sheet.
-Additional export formats are now available (standard Quicktime list).
-Snap to grid feedback while dragging has been implemented
-Some key modifiers have changed. In the past, option-drag has had the effect of
ignoring snap-to-grid. This functionality has been changed to be more consistent
and modern. Now, option-drag will create a copy of the object if the drag is to the
same document. To ignore snap-to-grid you should now use command-drag.
Command-option-drag now creates an EGO copy of your chart in the target
application.
-Toolbox position is now saved when you quit DeltaGraph
-Several new keyboard shortcuts are available:
-Command-Shift-G does the same as going to the Draw menu and choosing
Group
-Command-Shift-U does the same as going to the Draw menu and choosing
Ungroup
-Command-Shift-D does the same as going to the Draw menu and choosing
Shadows
-Command-Shift-C does the same as going to the Edit and menu choosing



Colors
-Pantone half-tone color support in EPS image exports. To use this feature your
object must have a Pantone fore-color and a white background color. You must
then choose a pattern from the last 32 patterns (last 2 rows) in the pattern palette
with each progressive pattern representing roughly a 3% increase in the tone.
An exported EPS file will maintain the Pantone named color and a half-tone
value based on the pattern. Any other export type will interpret the pattern as a
normal pattern rather than a half-tone value.

-New Features Specific to Mac OS X:

-PDF Import. DeltaGraph can now import PDF images to chart pages.

-PDF Export. PDF has been added as one of the supported export formats.
Rather than printing to PDF, which prints the whole chart page, you can now
export individual charts or objects as PDF images.

-Improved export quality on non-embedding export formats (JPG, BMP, TIFF, etc.).
Our export process has been retooled to take full advantage of the Quartz engine
when exporting these image types. Any applicable export options (such as the
standard JPG Quality slider) are also available. This gives users the ability to
produce some extremely high-quality images no matter what format is used.

-Export resolutions up to 1200 ppi are now available for all export formats.

-All text is now fully rendered using Quartz.

-Transparency support. You can now add transparency using the new
transparency tool in the tool palette. Transparency effects will be maintained if
you export the image in all formats except for EPS or PICT. Transparency layers
are maintained when you export the image as a PDF.

-Support for soft drop shadows when running on Mac OS X v.10.3 or higher.
Running on 10.3+, DeltaGraph, provides an additional option in the Shadow
dialog.

-Also included are many bug fixes. The following problems are among those
fixed for this version:

-A problem where double-clicking the DeltaGraph title bar (for window shading) in
OS 9 made the window disappear

-Several similar crashes caused by importing Excel files

-A problem where JPG and other images exported at higher resolutions were
getting shrunk

-A registration problem where typing a company name that exceeds 31 characters
caused DeltaGraph to reject the serial number

-A multi-user environment problem where users other than admin were not able to
access the standard library.

-When opening a very large file the watch cursor now appears.

-A crash caused by removing data after using it for a curve fit

-Superscript and subscript characters no longer move during export

-When the axis is a date, the up and down arrows in the Value Axis dialog now
adjust the Beginning and End dates according to the Minor Increment rather than
in seconds.

-Scrolling should no longer produce drawing problems

-Out of range alert should no longer be triggered when opening the Overlay
Dialog.

-A crash seen when trying to export Multiple Pie chart

-Copy/Paste now working from data view to chart view

-A problem where chart page names were showing up incorrectly

-Adjusting pie chart depth should no longer throw an error

-A problem where Symbol Font characters were showing up incorrectly.

-Year format now defaults to four digits for all years rather than only years after
2000. This also addresses a problem found when changing axis start or end
dates when there is a mix of year formats.

-"Set All" key command should be working again

-Crash no longer occurs on startup when system language is set to Japanese

-A problem where highlight color can get progressively darker



-Highlight should no longer get reversed when editing bullet lists

-A problem where lines can be printed too thick under some circustances

-A bug where symbols weren't being exported in some cases

-Line length in legend symbols is now adjustable for all chart types

-A very old problem where charts may not be properly updated with the correct
data under very specific circumstances

-Table charts can now be plotted with only one column of data

-A problem where rotated text can appear to go away after a font size change

v.5.0.2
Includes the following enhancements:
-Support for MacOS 9
-Updated Microsoft Excel file import and file linking capabilities. For instructions
on using this feature see the "Data Linking.pdf' document included in the
DeltaGraph 5/User Documentation folder.
-Text file data linking has been reinstated. For instructions see the "Data
Linking.pdf' document mentioned above.
-Several bug fixes

v.5.0.1a
Primarily includes bug fixes for the following issues:
- A fairly rare problem where DeltaGraph may report that there is another user
with the same serial number on the network when that's not the case.
- A problem where some rotated text was being moved upon print/export.

v.5.0.1
Primarily includes bug fixes for the following issues:
-A problem which can cause DeltaGraph to crash upon startup for some users.
-A bug which causes DeltaGraph to crash after updating a linked Excel file.

v.5.0
The primary new feature in 5.0 is native support for Mac OS X. In addition to a
fully aquafied user interface, support for Quartz rendering for graphics and text is
included. PDF export (via the Print dialog) is also supported.

Il. Known Issues and Work-Arounds:

You will see odd behavior if text is edited when zoom/scale is set to something
other than 100%. The cursor will often appear to be in a different place than
where the text is being edited and the text will appear to move or disappear. The
problem is especially apparent when styled text is present. The workaround is to
only edit text when zoom or scale is set to 100%.

Japanese text entered in a Windows font that supports japanese characters (eg
Arial) in a DeltaGraph for Windows file may not show up correctly in DeltaGraph
for Macintosh if the corresponding Mac font doesn't support Japanese characters.
The workaround is to change the font to a japanese font after opening the file on
the Mac side.

When the Equation Editor is launched from the Edit menu, two Editor windows
may appear under Mac OS X 10.2.8.

Pantone colors cannot be converted between Deltagraph for Macintosh and
DeltaGraph for Windows.

OLE Objects in DeltaGraph for Windows files will not be converted when opening
in Deltagraph for Mac.

Some fonts may not not be available when opening files from DeltaGraph for Mac



on Windows or vice-versa. Substitutions will be made where necessary.

The Slide Sorter doesn't exist in DeltaGraph 5 for Windows. This will not be
available when opening files on DeltaGraph for Windows. Files from DeltaGraph
for Windows opened on the Mac side will have one created for them. This also
applies to the Outliner view.

Mac OS X users who have Quicktime 5 installed may see a problem where all
raster-type images (any from the "File->Export->As Other..." list) get exported as
100 x 100 pixels. This is a Quicktime bug and can be solved by updating to the
newest version. This problem will only be apparent with DeltaGraph versions
later than 5.5.

The DeltaGraph 5.7 installer will install the DeltaSym, DeltaSymbol. TT, MT Extra,
and MTEXxt fonts in one of two places: /Library/Fonts or Home/Library/Fonts. If you
are a non-administrative user with no write access to the root-level Fonts folder
then the installer will place the fonts in your user-level fonts folder.

For this release the text tool is not able to create fully justified text.

Due to a system bug we do not support using Quartz soft drop shadows with any
object which uses a pattern. Doing so may cause DeltaGraph to crash when
printing the object. The bug has been reported to Apple. Please note that Quartz
soft drop shadows are only available if you are running Mac OS X v.10.3 or
higher. The workaround is to export the image first and then print it.

Exporting charts via EPSF has potential problems with printing, since fonts used
in an EPSF file are not automatically downloaded to a printer. This is a general
issue with Mac OS X. See the following article for the workaround:
http://support.redrocksw.com/dgknowledge/question.php?qstld=188

The Pantone™ color set has changed since DeltaGraph 4.5 for Macintosh.
Because of this, Pantone™ color names will not be preserved for files created in
DeltaGraph 4.5 when opened and saved in DeltaGraph 5 (however the color
information will be correct).

DeltaGraph help will display in your default browser ( set in the Web tab of the
Internet pane of System Preferences ). We recommend Safari, any of the Mozilla-
based browsers ( Firefox, Communicator, Camino, etc.), or Microsoft Internet
Explorer.

lll. Contacting Technical Support

-To open a technical support case or to access our knowledge base please visit
our support website:
http://support.redrocksw.com

-For technical problems which cannot be resolved using the above resources,
contact technical support by e-mail. When contacting us PLEASE INCLUDE A
NOTE ABOUT THE VERSION OF DELTAGRAPH YOU ARE USING ALONG
WITH YOUR OPERATING SYSTEM AND A DESCRIPTION OF THE PROBLEM.
This will greatly speed up the process of providing a solution for your issue.

E-mail: support@redrocksw.com

To be eligible for technical support please register your copy of DeltaGraph here:
https://secure.redrocksw.com/registerdgbmac

The DeltaGraph Team



Red Rock Software, Inc.

10 West Broadway, Suite #475
Salt Lake City, UT 84101
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